Partial Service Outage for YugabyteDB Aeon on Microsoft Azure
Incident Report for YugabyteDB Aeon
Resolved
We are pleased to announce that the service disruption affecting YugabyteDB Aeon deployments on Microsoft Azure has been fully resolved.

Update Summary:

New Cluster Creation: Fully operational on Azure.
Scaling Operations: Scale-up and scale-out processes are now fully operational for all customers.
Existing Clusters: Fully operational and unaffected throughout.
Other Platforms: Deployments on other cloud platforms remain unaffected.
We sincerely appreciate your patience and understanding as our team worked to address these issues. If you have any further questions or concerns, please don’t hesitate to reach out to our support team.

Thank you for choosing YugabyteDB!
Posted Jan 04, 2025 - 05:01 UTC
Update
We are pleased to share an update regarding the service disruption affecting YugabyteDB Aeon deployments on Microsoft Azure.

Update Summary:

New Cluster Creation: Resolved and fully operational on Azure.
Scaling Operations: Scale-up and scale-out processes are fully operational for new customers; however, these operations remain affected for existing customers.
Existing Clusters: Fully operational and unaffected.
Other Platforms: Deployments on other cloud platforms remain unaffected.

Our engineering team continues to work diligently to resolve the remaining issues. We will provide further updates as progress is made.

Thank you for your patience and understanding.
Posted Dec 31, 2024 - 23:17 UTC
Update
The root cause has been identified: On December 30, 2024, AlmaLinux replaced its previous Azure Marketplace offer for AlmaLinux OS images with a new one. This change is currently affecting the creation of virtual machines using the previous AlmaLinux OS images on the Azure platform. The YugabyteDB Aeon Team is actively working to transition to the new Azure Marketplace offer with new AlmaLinux OS images to fully restore service functionality. Further updates will be provided as more information becomes available.
Posted Dec 31, 2024 - 05:53 UTC
Identified
We are currently experiencing a partial service disruption impacting YugabyteDB Aeon deployments on Microsoft Azure.

Impact Summary:
• New Cluster Creation: Temporarily unavailable on Azure.
• Scaling Operations: Cluster scale-up and scale-out processes are affected.
• VM-Dependent Operations: Actions requiring new virtual machine creation are impacted.
• Existing Clusters: Fully operational and unaffected.
• Other Platforms: Deployments on other cloud platforms remain unaffected.

Our engineering team is working diligently to resolve the issue. Updates will be provided as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Dec 30, 2024 - 21:04 UTC
This incident affected: YugabyteDB Aeon Management Services.