Issues with Cluster Creation and Editing

Incident Report for YugabyteDB Aeon

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 10:38 UTC

Monitoring

Monitoring
Posted Jul 16, 2026 - 10:36 UTC

Investigating

Impact: Users may experience failures or delays when attempting to create or edit clusters. Active, running workloads are completely unaffected.

Root Cause: A third-party CDN provider (AWS CloudFront) is currently experiencing an outage, impacting our ability to securely fetch required package dependencies during provisioning workflows.

Current Actions: While we await a resolution from the cloud provider, our engineering team is actively working on a workaround to restore standard provisioning flows. We will provide updates as new information becomes available.
Posted Jul 16, 2026 - 10:23 UTC
This incident affected: YugabyteDB Aeon Management Services.