Major outage of Yugabyte DB Aeon Management Services

Incident Report for YugabyteDB Aeon

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 11:19 UTC

Monitoring

Update - The control plane service disruption has been resolved, and all functionality has been restored. We have confirmed that all services are now operating normally, and we are continuing to monitor the situation. The issue was diagnosed as a misconfiguration in a runtime flag, which was fixed later. All management and configuration operations are working after fixing the runtime flag.

We apologise for any inconvenience this may have caused.
Thank you for your patience and understanding as we work through this issue.
Posted Oct 07, 2025 - 09:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 07, 2025 - 08:06 UTC

Investigating

We have identified a partial service disruption affecting control plane operations. Our engineering team is currently investigating the issue.

Impact Summary:
• Creating, modifying, and deleting resources (clusters) may be failing or experiencing delays.
• Management APIs and consoles are affected, which may prevent access to administrative dashboards and configuration tools.
• Automated deployments and scaling events may not be functioning as expected.

Status:
• Existing services and running applications are not affected. The data plane remains fully operational, and live traffic is being served without disruption.


We will provide an update within the next hour.
Posted Oct 07, 2025 - 07:12 UTC
This incident affected: YugabyteDB Aeon Management Services.